21 Temmuz 2012

iTunes Kandırarak Firmware Yüksek Gösterme


Öncelikle, 3g telefonumu iTunes'e bağlayınca ortaya çıkan görüntüyü paylaşalım. :)



Gelen bir istek doğrultusunda yazmayı düşündüm. :) Öncelikle uygulamanın faydası olur mu olmaz mı, o sizin şansınıza kalmış. iTunes üzerinden diyelim 4.1 firmware yüklü telefonunuza uygulama indireceksiniz.. Fakat Appstore buna izin vermiyor. Neden? Çünkü ios 4.2 istiyor uygulama en az. Veyahut 5.1 istiyor.. Biz ne yapacağız? AppStore ve iTunes'i kandıracağız. :)

Gerekli iki program:
1-iFunBox
2-Wordpad ya da Not Defteri

1)

Öncelikle, App Store'u iOS 5.1 yüklüymüş gibi düşündürmek için;


System/Library/CoreServices/

klasöründe bulunan SystemVersion.plist dosyasını yedekleyin ve ardından dosyayı açarak,
<key>ProductBuildVersion</key>
<string>9A405</string>
( Firmware'nizde ne yüklüyse o numara yazar. O yüzden sizin değiştirmeniz için bilmeniz gereken tek kısım bu.

9A405 yazan kısmı

<key>ProductBuildVersion</key>
<string>9B176</string>

9B176 olarak değiştirin,

ve


<key>ProductVersion</key>
<string>5.0.1</string>
(Hangi sürüm yüklüyse o sürümün ismi geçerlidir. Örn: 4.2.1 gibi.

5.0.1 yazan kısmı

<key>ProductVersion</key>

<string>5.1</string>

5.1 olarak değiştirin ve dosyayı kaydedin.


Daha sonra,

User/Library/Preferences/

klasöründe bulunan com.apple.springboard dosyasını yedekleyin, ardından dosyayı açarak,

<key>SBSoftwareUpdateOSVersion</key>
<string>5.0.1:9A405</string>


yazan kısmı

<key>SBSoftwareUpdateOSVersion</key>
<string>5.1:9B176</string>


olacak şekilde değiştirin.

Bu işlemler sonucunda yapılacak respring sonrası Activator tweak'i yüklü ise sisteminizi 5.1 gibi algılayacağından "System too new" uyarısı görünecek ve bir takım springboard düzeni bozulabilecektir (örneğin infinidock gibi) veya safemod'a atmalar yaşanabilecektir.


2)

App Store'u kandırma yolu ile iOS 5.1 şartı koşan uygulamaları iOS5.0.1 sisteminize yükledikten sonra, bu uygulamları çalıştırmak için de sisteminiz iOS 5.1 yüklüymüş gibi düşündürmek gerekli.

ilgili her uygulama için yapılacak işlem;

ilgili uygulamaya ait klasörü bulmak (örn, iPhotos.app veya iMovies.app vs vs) ve uygulamaya ait
Info.plist dosyasını bularak aşağıda belirtilen değişiklikleri yaparak kaydetmek olacaktır.

Herbir uygulamaya ait Info.plist dosyasında;
<key>MinimumOSVersion</key>
<string>5.1</string>


yazan kısmı
<key>MinimumOSVersion</key>
<string>5.0.1</string>


olarak değiştirin ve dosyayı kaydederek, respring yapın.

Eğer Safe Mode'dan kurtulamıyorsanız her adımda editlediğiniz dosyaların orjinal yedeklerini ilgili klasörlere geri yükleyerek eski ayarlarınıza dönerek Safe Moda'dan çıkabilirsiniz.
Safe Moda atma sorunu olmadıysa iOS 5.1 şartı gerektiren uygulamaları sisteminizde kullanmanın tadını çıkarabilirsiniz.

 NOT: Cihazınız 3G ise, programların açılıp açılmama konusunda garanti veremem. Fakat CYDİA'dan yükleyeceğiniz tweakleri, yeni ios sistemine uyarlanmış hâliyle açacaktır.
Previous Post
Sonraki